
Marks Management & ScanExam Introduction 
 
1. Install Marks Management Software (MMS) and ScanExam 
First uninstall your old version of MMS.  Then, use a web browser to visit 
ssnds.uwo.ca/softwaredownloads.html and download the install package into a temporary 
folder on the C: drive. Double click the files to execute the software installation.  The 
MMS file download name is mmsvb6zse.exe and the ScanExam name is scanxiizse.exe. 
 
You may register to receive e-mail notifications of new releases and bug reports by 
clicking on the Registering link. At any time you may Remove yourself from this list 
using the links on the software download page. 
 
2. Marks Management 
 
Run the MMS software from: 
Start > All Programs > Marks Management > Marks Management 
 
The MMS Environment   
HELP within MMS:   
The HELP menu command provides the best source of documentation for all the features 
and operations of the software. A Table of Contents and full text word/phrase searching is 
provided for finding information. A quick lookup of a help topic for any of the 
commands that appear in the menus is provided by pressing the F1 key while the 
command is highlighted.  Also, check the FAQ at ssnds.uwo.ca/softwaredownloads.html.   
 
Screen Views 
There are four views available from the View menu. The view may be changed at any 
time. 

• Grid Only displays student and grade information only.  
• Grid with Statistics and Notes displays fewer students on the screen but 

includes column statistics, graphs, Student Summary, E-mail Address and 
Instructor Comments.  

• Grid with Student Photo displays student pictures if they are available (see 
HELP for more information).   

• Class Photo Sheets displays photos without the grid. 
 
Editing MMS Files: 
Most cells in a MMS file may be edited by first clicking the mouse pointer in the cell to 
be changed. When a cell is in edit mode its background colour is white. Movement is 
as follows: 

• Tab key to move to the right.  
• Shift+Tab to move to the left. 
• Enter key to move down to the next student within a column. 
• Down arrow to move down to the next student within a column. 
• Up arrow to move up to the previous student within a column. 
• Horizontal scroll bar above the grade columns is used to move across grade 

columns A through AZ. The quantity of grade columns appearing on the screen 
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can be increased or decreased by stretching or shrinking the application window 
and is restricted only by the capacity of the screen.   

• Vertical scroll bar on the left for scrolling through students. 
 
The formula cell may not be edited directly, rather it is set by selecting one of the items 
available from the FORMULA menu.  
 
The student Status cell (e.g.WDN), course section, and Career Codes fields can not be 
edited and are changed only under program control using information from a Registrar's 
class file Initialize/Update command. 
 
Flagging: 
Students can be flagged for various functions which we will cover later.  To flag a 
student, select the student you wish to flag and choose Edit > Flag Operations > 
Flag/Unflag student.  There are various other flagging options available from the Flag 
Operations menu item, including keyboard and mouse shortcuts. 
 
A few of the common uses for flagging are: 

• to limit the print of grades to one or a selected group of students 
• to send e-mail to one or a selected group of students 
• to flag all students prior to a Registrar’s Class List Update which will result in 

quick identification of students in an MMS file who are not found in the class list 
by sorting on the Flag/Section option 

• to generate Registrar grade revisions for one or a select group of students 
• to save a group of students to a separate file 

 
Sorting: 
Using the Tools > Sort command you can sort (or order) your MMS file.  The MMS file 
may be arranged as follows: 

• in alphabetical order by last name or career code 
• in ascending order by student number or section number 
• in ascending or descending order based upon alpha or numeric content in a grade 

column 
MMS sorts are special insofar as secondary keys and missing value codes are 
automatically applied.  For example, the last name sort automatically uses the first 
name as a secondary sort key, a career code or section code sort uses the last name 
and first name as secondary sort keys.  Sorting by the content of a grade column will 
force all Registrar special codes to the top (ascending sorts) or to the bottom (descending 
sorts). 
 
Note: Certain MMS routines also use the sort to force the file to be rearranged to facilitate 
various tasks or computations (e.g., a Registrar class list update, Registrar grade 
printouts). 
 
Saving: 
MMS files are now stored in an encoded format to help ensure that their contents are 
better protected against accidental disclosure or access to private student information.  
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Before saving an MMS file the instructor must create either an Instructor PIN (8-12 
digits) and username or a department PIN and username or both.  Both are recommended.  
Choose File > PIN(s) to assign both the Instructor PIN and the Department PIN.  You 
must enter your Western username when you enter the PIN.  If you forget your PIN, then 
you will be prompted to log in using your Western account and your PIN will be 
displayed for you.  It will only work for that username.  After you assign a PIN, you can 
choose any of the File > Save options or File > Exit and save the file while exiting.   
 
Initialize MMS Class File from Registrar Class File    
If you intend to use MMS to submit your grades to the Registrar, then you must initialize 
your file using a Registrar Class List.  This can be obtained as follows: 

• Registrar’s Faculty/Staff Extranet – Registrar Class list files and student photos 
are available from https://www1.regx.uwo.ca/extranet.  To gain access to this 
service you must complete the first two pages of the Request for Access to 
Corporate Information form found at 
www.uwo.ca/its/accounting/crpfrm.html (Check OOR ExtraNet Only).   

• PeopleSoft Student Centre – Most undergraduate administrators have access to 
this and it can be used to download class lists.  If you have Peoplesoft access, then 
you can access the Extranet as well. 

   
Choose File > New or File > Initialize or Update from Registrar Class File…  The 
program will display files in the current folder with the extension .rcl. 
 
As a term progresses, or at least prior to submitting final grades, a current class list 
should be obtained and used to update the MMS file to properly reflect student status 
changes (e.g.WDN), late adds and drops. 
 
Setup Grade Breakdown  
 
This step can be completed either before or after entering grades.     
 

• TitleA  To enter your own title at the top of each column, just click on TitleA and 
type in your title. 

 
• Perfect  The number you enter here depends on whether you have entered the 

grades as a raw score or as a percentage.  If the grades are a percentage then 
Perfect should be 100.  If you entered a raw grade out of 15 then Perfect should 
be 15.  Column statistics are calculated based on a Perfect score of 100 unless 
specified otherwise. 

 
• Weight  If a particular test makes up 10% of the final grade, then the weight 

should be entered as 0.10.  The weights of all columns used in the final grade 
calculation should total 1.00.  If a column will not contribute directly to the final 
grade calculation you do not need to specify a weight. 

 
• Formula  If, for example, you had four labs but students only had to complete 

three of them, or only the top three grades would be included in the final grade, 
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you would enter a formula to calculate the Best 3 of 4.  If an exam is made up of 
multiple choice questions and essay questions, you would want to calculate an 
exam score by totaling the multiple choice mark (entered from ScanExam) and the 
essay mark.  You can create custom formulae or use boxed ones. 

 
Enter Grades  
There are four different ways to enter grades into MMS: 
 

• File > Load ScanExam grades into column… You will be prompted to select 
the column letter in which you wish the grades to go.  The ScanExam output file 
has the extension .dpc and a DPC file contains lines of data that have the format 
of student number, some delimiter, and grade (see example in handout).  
Therefore, this menu item will load both ScanExam output files and any other 
grade files formatted as DPC files. 

 
• Edit > Match Paste from Clipboard to MMS…  You can cut and paste marks 

from Excel. The transfer of a student number column and a grade column from a 
spreadsheet (e.g. Excel) requires that the two spreadsheet columns appear 
adjacent to each other with the student number column always being the first 
column.  Once you have copied the information from the spreadsheet to the 
clipboard, in MMS choose Edit > Match Paste from Clipboard to MMS. You 
will be prompted to select a column letter into which the grades will be pasted.  
All non-matches are rejected into an error file for subsequent resolution. 

 
• Edit > Match Copy from MMS to Clipboard… Copy Marks from another 

MMS file into your MMS file.   
 

1. Open Marks Management twice; one with the Master MMS file and one with 
the lab/tutorial section MMS file.   

2. In the Lab section MMS file choose Edit > Match Copy from MMS to 
Clipboard (select the final grade column identifier).  

3. In the Master MMS file choose Edit > Match Paste from Clipboard to 
MMS (select the column identifier representing the column where you wish to 
place the lab grades).  For students not in the current lab section an NGR will 
be inserted. When adding subsequent lab sections you will receive a warning.  
You should click on NO so that the column is updated and NOT overwritten.  

4. Repeat until all lab sections have been entered. 
 

• Enter Grades Manually.  Marks from things like term papers and essay tests 
may need to be entered manually.  Simply click in the cell and enter the grade. 

 
Note: Whenever you see ** Calculate Recommended ** at the top of your screen, it 
means that the program recognizes that a change has been made which would change 
either a student’s calculated grade or summary statistics.  Unlike spreadsheets which 
update dynamically, MMS displays the Calculate message and allows you to choose the 
timing of the recalculation.  You will be prompted to press calculate before critical 
functions such as submitting grades, or sending grades via e-mail. 
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Calculate Final Grades   
Under Help you should read the Built in Formulae > Final and Term Grade Calculations 
to see what’s available.  We will just cover the basic final grade calculation in this course. 
 

• Formula > Specify columns for final grade calc.  If you set up the grade 
breakdown at the outset, you may have already taken care of it.  Ensure that all 
columns contributing to the final grade calculation have weights that add up to 
1.00.  Specify the input columns and the output column and click OK. 

• Rounding and Bumping.  You may choose to experiment with rounding and 
bumping the final grade into other columns.  Formula >Round a column of 
grades or Formula > Round and Bump 9’s.  Marks are rounded when they are 
submitted to the Registrar so it would be wise to round your final grade column to 
save a copy of the rounded grades in your MMS file. 

 
Submit grades to the Registrar  
 

• File -> Registrar Reports -> Grade Submission -> e-file form > Create and 
send file to Registrar.  Choose the column letter representing the column that 
contains the final grade (please select the column letter CAREFULLY as this is a 
possible source of ERROR).  You will be prompted to enter your UWO Username 
and Password.  Read the summary screens carefully to confirm that the file has 
sent and where a copy of the file is saved. 

• If you are off campus choose File -> Registrar Reports -> Grade Submission -> 
e-file form > Create file only.  This will save an encrypted copy of the grade file.  
Contact your department for instructions on submitting it. 

• All encrypted grade files are saved in a subfolder called gradesubmissions in your 
current folder. 

• Encrypted grade files can be viewed by choosing File -> Registrar Reports -> 
Grade Submission -> e-file form > View encrypted files. 
 

Print grades 
 

• File -> Registrar Reports -> Grade Submission -> print form and select the 
letter representing the column where the final marks are listed.  This produces a 
copy for signing should your department require that. 

 
• File > Print There are a number of options to choose from.  Only print options 

labeled (masked ids) are appropriate for posting grades on your door.  The first 4 
digits are masked and the remaining digits are sorted numerically to abide by 
FIPPA regulations. 

 
Grade Revisions 
Simply enter the revised grades in a column to the right of the original grade.  Then flag 
the student(s) whose grades need to be revised (double-click student and * appears in 
section column).  Ensure that the revised grade is in a column to the right of the original 
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grade.  Then File > Registrar Reports > Grade Revision > e-file form (see Submit 
Grades to the Registrar above) or print form.  Select the columns representing the 
originally submitted grade and the revised grade.  As above, all encrypted grade files are 
saved in a subfolder called gradesubmissions in your current folder. 
  
WebCT-OWL 
You can transfer grade information from MMS grade columns to WebCT-OWL 
Instructor GradeBooks and from WebCT-OWL GradeBook columns into MMS grade 
columns. UWO WebCT-OWL and MMS differ somewhat in how they manage student 
information. WebCT-OWL uses the student’s unique Western e-mail address while MMS 
uses the Registrar’s unique student number. MMS also maintains student e-mail address 
information so it is capable of linking its information to WebCT-OWL, however it is 
important that both the MMS and the WebCT-OWL files are initialized from Registrar 
files to ensure accuracy between the two systems.  

Export MMS Grade Column(s) Directly into WebCT-OWL Gradebook 

MMS grade columns may be exported directly into a WebCT-OWL gradebook via the 
Grade Upload module.  In order to run, the module requires that Java is installed on your 
computer.  Choose Tools > WebCT-OWL > Export MMS grade columns directly 
into WebCT-OWL Gradebook. Follow the more detailed instructions in MMS Help.  

Please contact the UWO WebCT-OWL support staff if you require assistance or have 
difficulties obtaining the required module for using this feature. 

Import Grades as CSV for WebCT-OWL 

WebCT grade columns exported into a file using the WebCT-OWL CSV export format 
can be directly loaded into MMS grade columns by choosing Tools > WebCT-OWL > 
Import WebCT-OWL Grade Columns CSV into MMS. 
 
Note: A WebCT-OWL export CSV file may have multiple grade columns, however the 
loading of a multiple columns file must be done in MMS one column at a time. MMS 
will prompt for both the desired WebCT-OWL named column which is to be loaded and 
the MMS destination column. 
 
E-mail Grades to Your Students 
You can use MMS to send e-mail’s to the students in your class.  If you use this feature, 
the students should be instructed to either use their University e-mail address or set 
automatic forwarding of their UWO e-mail. 
 
Choose Tools > Send E-Mail.  The default settings will have the Mail From address set 
to noreply@uwo.ca and the SMTP Mail Server will be smtp.uwo.ca.  If you wish to 
change either of these, just click on the item and it will go into an edit screen. 
 
First you must Flag the students to whom you are sending e-mail.  Then choose Tools > 
Send E-Mail > Send Message, Grades, Attachments…  Type any text you wish to 
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appear in the message.  To attach grades, click on the box beside Grades and select the 
grade columns you wish to send.  To attach a file, click in the box beside Attach File # 
and browse and select your file.  When you are ready to send the message, click Send at 
the top.  You will be notified when the messages have been sent.  A copy of the sent 
messages will be saved in your current directory under mailfolder#  by student number. If 
you wish to see what the e-mail will look like first, choose Tools > Send E-mail > Send 
Sample E-mail to Instructor. 
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3. ScanExam-II 
 
Run the ScanExam software from: 

Start > All Programs > ScanExam-II > ScanExamII 
 
The ScanExam Environment   
The HELP menu command provides the best source of documentation for all the features 
and operations of the software. A Table of Contents and full text word/phrase searching is 
provided for finding information. A quick lookup of a help topic for any of the 
commands that appear in the menus is provided by pressing the F1 key while the 
command is highlighted.  Also, check the FAQ at ssnds.uwo.ca/softwaredownloads.html. 
 
Navigating 

• The Browse Forward and Browse Back buttons permit sequential browsing 
forward and backward through the file.  

• The Flip Page button turns over the sheet to view questions 61-180.   
• You can also find a specific student number by choosing Edit > Find Student 

and enter the student number you are searching for.   
• The Serial # is a number assigned by the scanner.  This is a feature that ITS has 

on their scanner.  If there are no Serial Numbers assigned (as in SSC), ScanExam 
assigns them sequentially starting at 0001. 

• The Exam Code must be used when multiple versions of exams are written 
(111,222,…). 

 
Screen Views 

• Student Scan Sheets:  This is the Default view.  Displays student answers as they 
appear on the answer sheet.  Click to shade or unshade an answer choice.  Grading 
on right changes dynamically as you make changes.  Cyan highlights indicate 
problems.  Red question numbers indicate wrong answers. 

 
• Exam Analysis:  Display of various statistics that you can select from the menu at 

the bottom left of the screen.  All statistics use student percentage scores rounded 
to one decimal place and not Raw scores. 

 
• Master Answer Key:  Looks just like the Student Scan Sheet view except the 

navigation buttons on the left are gone, the student number is 999999999 and the 
Exam Code is fixed as blank or 000.  A question with no answer is displayed as 
cyan.  If a question has more than one answer, the second answer is not displayed. 

 
 
ScanExam supports two formats.  The extended format allows for more answer choices 
as well as multiple answers.  (Show Format > Extended Multiple Responses and show 
the sheets).   
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Bring the exams to be scanned 
 
If your course is a Main Campus Social Science course you can bring your scan sheets to 
our main office for scanning.  You should check with the office for the procedures for 
submitting exams to be scanned.  If ITS is scanning your exams, you should check with 
them for instructions.  
 

• The exams will be scanned and the results will be e-mailed to you as a DAT file.   
 

• Save that DAT file to your hard drive and make a note of the folder where you 
saved it. 

 
• You should reclaim the scanned sheets for later reference.  

 
Open a DAT file in ScanExam-II    
Choose File > Open DAT File (Scanned Exams).  Open the file from the location where 
you saved it from your e-mail.  The default in ScanExam assumes that all questions have 
a weight of 1, the score is the sum of the weights with no penalty, there is a single version 
of the exam, and there is only one correct answer for each question.  The Scan Error 
Summary is displayed when the file is opened for your attention. 
 
Enter the Master Answer Key   
Normally a Master Answer Key is handed in with the ScanExam sheets to be scanned.  
The student number is 999999999 and the Exam Code is blank or 000.  If you did not 
include a Master Answer Key, then you must enter one now. 
 
Click on View > Master Answer Key.  You will be prompted to enter the number of the 
last exam question.  After that, the answer key will be displayed and all answers will be 
cyan.  For each question, click on the correct answer choice. 
 
Load Master Answer Key  
This is an ideal solution for classes with multiple sections writing the same test.  With 
this method, there is no Master Scan Sheet, or multiple copies of it, that can be lost.  
Enter the Master Answer Key in a ScanExam file.  Enter your Exam mappings for 
multiple versions of the same exam.  Then save it by choosing Options > Save Options 
into an OPT file.  Send the OPT file to the TAs responsible for marking.  The TAs then 
open a DAT file and choose Options > Load Options from an OPT file.  (Later if a 
question is determined to be a bad question, the correction can be made to the OPT file, a 
new version can be sent to the TAs and loaded.)  There is very little room for error. 
 
 
Check the Data    
 

• Edit > Scan Error Summary.  Locate each sheet with errors by clicking the 
Find Next ERROR command button.  Questions with errors are displayed in 
cyan.  Errors are caused by incomplete erasures, more than one answer choice 
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being selected, faint answer marks, blank answers, missed or multiply marked 
bubbles in the student answer field, or a missing exam or section code if these are 
used.  Compare errors with the original sheets. 
 
To search for specific types of errors, choose Edit > Find and select an option 
from the menu.  You can also click on the Find Next ERROR button in 
combination with other keys.  You can see the key combinations when you hover 
over the Find Next ERROR button. 

 
• Edit > Validate Student Numbers.  You can validate the student numbers in 

your ScanExam file against a Registrar’s Class List file or the MMS file for the 
class.  Any exam sheet student number that cannot be matched against the 
authority file is reported in a list on the screen.  Locating invalid sheets must be 
done by using the Edit > Find Student command.  

       It is Important to do this before you load the scan exam grades into MMS. 
 
 
Check for bad questions  
 

• View > Exam Analysis > General Item Analysis.  There are a lot of things in 
the General Item Analysis that we won’t cover in this course.  You can read about 
them in the Help on in the User Notes on the web.  One important and easy thing 
to look for is a Zero or Negative Point Bi-Serial.  A negative point bi-serial means 
that the worst students got the answer right while the best students got it wrong.  
Zero means either nobody or everybody got it right.  That could indicate an error 
on the answer sheet or an ambiguous question or answer choice. A point bi-serial 
of +.30 and above is very good. 

 
Apply Custom Weights 
 

• Choose Options > Custom Weights.  The default weight for each question is 
one.  If you wish to change that for any questions, scroll through the question and 
simply enter the changed weight.  Click on OK once you have entered all the 
weight changes. 

 
Transfer Grades to Marks Management  
Tools > Create DPC file (for MMS loads) and choose either percentage grades or raw 
score.  If you choose raw score remember if you have excluded a question.  The file is 
created with a .dpc extension that you will be prompted to name and save in the folder of 
your choosing.  It’s important to remember where you save the file.  The output file is 
compatible for loading into the Marks Management System (MMS) as well as spreadsheet 
packages such as Excel.   
 
Transfer Grades to WebCT-OWL 
Tools > Create CSV file (for WebCT-OWL loads) and choose either percentage 
grades or raw score.  If you choose raw score remember if you have excluded a 
question.  The file is created with a .dpc extension that you will be prompted to name and 
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save in the folder of your choosing.  You will be prompted for an MMS or RCL file to 
validate against.  If you validate with an MMS file, you will be prompted to enter the 
Access PIN for that file.  The output file is compatible for loading into WebCt-OWL as 
well as spreadsheet packages such as Excel. 
 
Flagging Students 
The ability to flag students for a variety of purposes is provided both for Scan Exam 
purposes and for general uses by instructors. For example, Scan Exam uses flagging to 
control student e-mail sends, create subset DAT files, create subset Export CSV files, 
create subsets based upon subset exam analysis where exam codes and/or section codes 
are used. Flags placed on students are retained when a DAT file is saved.  Choose Edit > 
Flag Operations.  When a group of students are flagged for e-mails, the summary 
statistics sent with the e-mail are for the full class unless a subset is selected. 
 
E-mail Grades from ScanExam 
You must have an RCL file or an MMS file for your class before you can e-mail from 
ScanExam.   It is recommended that you validate student numbers (see above) before 
using this feature.  The ScanExam program will validate for you when you attempt to 
send mail and if there is a mismatch, the send mail will be cancelled.  As with MMS, if 
you use this feature, the students should be instructed to either use their Western e-mail 
address or set automatic forwarding of their Western e-mail. 
 
Flag the students you wish to e-mail.  Then choose Tools > Send HTML Student E-
Mails.  The default settings will have the Mail From address set to noreply@uwo.ca and 
the SMTP Mail Server will be smtp.uwo.ca.  If you wish to change either of these, just 
click on the item and it will go into an edit screen. 
 
When you use E-mail in ScanExam, only flagged students in the ScanExam file will be 
sent mail.  Choose Tools > Send HTML Student E-Mails > Send Scores, Answers, 
Exam Stats…  You will be prompted to select a corresponding MMS or RCL file.  If you 
validate with an MMS file, you will be prompted to enter the Access PIN for that file. 
Next, type any text you wish to appear in the message.  To attach a file, click in the box 
beside Attach File # and browse and select your file.  When you are ready to send the 
message, click Send at the top.  You will be notified when the messages have been sent.  
A copy of the sent messages will be saved in your current directory under mailfolder#  by 
student number. 
 
Before sending your message to students, you can choose to Send sample e-mail to 
Instructor.  The first flagged student’s grades will be sent to the instructor e-mail that 
you enter.  The students will remain flagged until the actual send. 
 
 
Exam Mapping  
When doing custom question or custom answer mapping, when taken from the 
perspective of the student writing the exam, ask where the question or answer would be 
found on the master key.  If the first question on my mapped exam is question 10 on the 
master key, then 10 is the mapping.  If the E answer is in the A position, D in B, C in C, 
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B in D, and A in E, then the mapping is EDCBA.  See the Help item for more 
information.   
 
There is also a Create Mapped Exams Tool which will assemble your exams from a bank 
of prepared questions while applying the preset or Custom mapping rules.  See the Help 
on Options > Preset Question Mapping and Tools > Create Mapped Exams (000-
999). 
 
 
Printing  
There are various print options that can be found by choosing File > Print.  For TAs 
consulting with students in their office where they might not have a computer, the option 
to Print Student Answers gives you a list that can be cut up and shown to students 
individually.  Additionally, Print Exam Analysis > Descriptive gives the score statistics 
and summary and three graphs and it is acceptable to post this information.  Finally, if 
you choose Print Option Settings you will see the answers and options as they apply 
individually to each of your mapped versions. 


